bootstrap4

今制作中のWebサービスで、レイアウトにbootstrap4を使おうという事になって、そのまんまをアサインしていこうと色々やってみたが、どうにもscssをいじらないことには、という感じなんで、しょーがないかと環境の現状をチェックしながらセットアップしていったら、npmが無いと言われる。npmが無いとgulpとやらが入れられず、gulpが無いとscssからcssにコンパイルできない(らしい)。で、nodeが入ってるとnpmは勝手に入るらしいが、node -vも通るし仮想サーバも立ち上がるんでちゃんと入ってるんだが、npmはどうやっても無いと言われる。

で、時間の合間を見て色々試して、昨日ようやく動いた。何てことはなく、最新バージョンの0.9.xを入れてたためで、stableとして0.8.xを入れると「何かありましたか?」ってくらい普通に動いた。

ああああ、こういうの久しぶりな感じ。w 最近めんどくさいこと避けてたからなあ。こまめに色々勉強しないとなあ。

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA